2.27K views
0 Comments

Moin Joy-IT-Team,
ist es möglich den Talking-Pi an einem Verstärker zu betreiben? Meiner Versuche bisher waren negativ.
Details:
Ich habe das Board um einen weiteren Kanal erweitert, so dass ich nun eine Stereo-Ausgabe habe. Nun möchte ich dahinter einen Verstärker betreiben. Resultat ist bei Anschluss von nur Plus (+) an den Verstärker erhalte ich einen Scratchy Sound, was ja auch logisch ist, da Masse fehlt. Sobald ich die Masse mit anschließe gibt es nur ein Rauschen.
Erweitert ist das Board mit
https://learn.adafruit.com/adafruit-max98357-i2s-class-d-mono-amp/pinouts
Aus der Beschreibung:

The outputs of each channel are „Bridge-Tied“ with no connection to ground. This means that for each channels, the + and – alternate polarity to create a single channel amplifier with twice the available power.

Könnte es daran liegen, und gibt es eine Möglichkeit das Problem zu beheben?
Vielen Dank
Thomas

Answered question

5 Answers

Guten Tag Thomas,
also es ist natürlich richtig, dass die Masse angeschlossen werden muss. Ihre Beschreibung des Problems legt die Vermutung nahe, dass es sich um eine Masseschleife (Erdschleife) handelt. Um zu testen ob es damit zusammenhängt muss der Verstärker galvanisch getrennt betrieben werden. Jetzt kommt es darauf an, was für einen Verstärker Sie nutzen. Wenn ihr Verstärker mit geringen DC Spannungen betrieben wird, können Sie diesen Test mit einem Akku, einer Powerbank oder auch einem Netzteil machen, welches einen Euro-Stecker (kein Schutzleiterkontakt) hat. Bei einem 230 V betriebenen Gerät wird es schon schwieriger. Es kann helfen, wenn man den Stecker in der Steckdose einfach einmal andersherum einsteckt. Einen informativen Beitrag zu diesem Thema aus einem DJ Forum finden Sie hier.

Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Anonymous 0 Comments

Hallo Nils,
danke schon mal für das Feedback. Als Verstärker kommt bei mir
https://learn.adafruit.com/adafruit-20w-stereo-audio-amplifier-class-d-max9744
zum Einsatz, da ich den via I2C steuern kann. Dieser läuft mit einem Netzteil (mit Schutzleiter) und einer Gleichspannung von rund 12V. Habe den Stecker auch mal umgedreht: keine Änderung.
Noch einmal zur Verdeutlichung: Klemme ich den Talking Pi an den Verstärker an (es läuft keine Musik), bekomme ich sofort so eine Art weißes Rauschen 🙁
Ich habe mal den RPi und Talking Pi mit der gleichen Spannung betrieben wie den Verstärker. Gleicher Effekt. Zuzüglich habe ich noch ein Radiomodul (SI4703) am RPi. Wenn ich das an den Verstärker anschließe bleibt der Effekt aus, der Sound ist klar und deutlich.
Es muß also mit dem Talking Pi zusammenhängen.
P.S.: Wenn ich den Talking Pi direkt an den Lautsprecher hänge, ist der Sound ebenfalls deutlich.
Gruß
Thomas

Answered question
Anonymous 0 Comments

P.S.: Hatte die Frage schon einmal hier eingestellt, sehe ich gerade:
https://talkingpi.joy-it.net/questions/question/lautsprecher-out-an-verstaerker/
Gruß
Thomas

Answered question
Anonymous 0 Comments

@Nils:
Das ist das Projekt von dem ich sprach:
https://www.youtube.com/watch?v=3dzsPGwNwMc&t=10s
Gruß
Thomas

Answered question

Guten Morgen Thomas,
leider habe ich noch keine neuen Informationen für dich. Ich hoffe, dass ich dir spätestens Montag weitere Informationen zur Verfügung stellen kann.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.